Automotive Forums  Where Car Enthusiasts Go to Discuss Cars Online

  
 
 
Home | Active Posts | Search | Log In / Register | Terms | FAQs
Xml
Item Posts   

PROBLEMS WITH 2010 DODGE AVENGER R/T

 
 | 
married2jr married2jr
New User | Posts: 1 | Joined: 11/10
Posted: 11/16/10
03:34 PM

Was wondering if any else is having multiple problems with their 2010 Dodge Avenger RT? I purchased one back on 1/23/10, it has roughly 14,000 miles on it. I have complained several times about the noise I hear coming from the front passenger side. First time, dealership told me it was "normal" engine noise, second time they said I had an exhaust leak and repaired that. When we went to pick the car up, as soon as we started the car we heard the noise. Seems to only do it when the car is cold, once it warms up, I don't hear the noise. Secondaly parts of my radio are not working, still waiting on a replacement radio. Then the speedometer stopped working and on the way to the dealership to get that serviced, my car would not come out of Park.  I had to have car towed from the store to the dealership.  They said something came loose and that was why the speedomter stopped working and the had to replace something in the gear shifter. I get my car back Saturday and now 3 days later, there is about 2 inches of water all over the floorboard on the front passenger side.  This car that I loved the moment I saw it and test drove it has become a nightmare. Anyone else having problems like this????  

Paul Broyles Paul Broyles
New User | Posts: 1 | Joined: 09/14
Posted: 09/13/14
08:31 PM

Hello , I also have a 2010 Dodge Avenger R/T the only problem I'm having is the water on the floorboard  under the passenger side and sometimes the driver, l also thought my Windows might have been left down the first time.Then l begin to hear a noise under the hood when a left turn is made and a slushy water sound.l took my vehicle to a Goodyear Service Center where l live , was told that a service bulletin required that a heat shield be placed under the hood firewall because heat from the car engine was causing the evaporator to produce large amounts of condensation and the drain plug is not plugged , then why is the water not running out on the outside of the car.l did not have this work done l'm waiting to hear if anyone else have this problem and what they needed to do to fix it.There answer to my vehicle problem don't add up Confused  

Just Try It1 Just Try It1
Moderator | Posts: 2796 | Joined: 08/14
Posted: 07/17/18
08:43 PM

you have not included which of the VERY Different motors that could be in that model

2.4L  2.7L or 3.5L

i would want to make sure that the cooling system is properly bled and not leaking..

leaks can be from the water pumps...  many other parts..

you will want to see this video... you may want to watch the whole thing but i am more worried bout bleeding the cooling system starting at 10:55 into the video.. there are 2 more parts.. 1 and 2 of that video you may want to view..

 

Xml
Showbuyersguide Hide2
2014 Dodge Avenger
Button Getmyprice
Body Style:
Sedan
Rating:
N

Research Categories: