Ad Radar

Automotive Forums  Where Car Enthusiasts Go to Discuss Cars Online

  
 
 
Home | Active Posts | Search | Log In / Register | Terms | FAQs
Xml
Item Posts   

03' Ram 2500 vent problems

 
 | 
Orcinius1 Orcinius1
New User | Posts: 2 | Joined: 12/09
Posted: 12/19/09
06:09 AM

My Heater core went a few months ago and I replaced that. The heat and vents worked fine but a couple of days ago I went to the store and when I came back out and started the truck the heat would not come off of vent. It was on def/foot going to the store but now it is only on face/vent. Its winter and this is a big problem. It still will not switch off vent can someone give me any ideas?  

waynep7122 waynep7122
Addict | Posts: 4561 | Joined: 08/09
Posted: 12/19/09
07:50 AM

who replaced the heater core?????  it is possible that a vacuum hose has failed... fallen off.. frozen with a little ice in the line..

i wonder.. if one of the blend doors has frozen in place????

that an actuator has failed...


i found that autozone.com has some information..

REPAIR INFO  2003 DODGE TRUCK RAM 2500 3/4 TON 2WD 5.7L SFI 8CYL REPAIR GUIDE  HEATING & AIR CONDITIONING   HEATING & AIR CONDITIONING SYSTEM COMPONENTS   AIR MIX MODE ACTUATOR BLEND DOOR

here a picture   you will have to copy and paste the link into a new window to view it..

http://repairguide.autozone.com/znetrgs/repair_guide_content/en_us/images/0996b43f/80/20/4c/a8/medium/0996b43f80204ca8.gif

HVAC housing, dual zone shown (single zone similar)-nut (1), passenger blend door actuator (2), nut (3), inlet baffle (4), recirc door actuator (5), recirc air door (6), driver side blend door actuator (7), HVAC housing (8), bolt (9), defroster door actuator (10), mode door actuator (11)

i would say.. that the actuators in spots 10 or 11 are probably causing your problem...   it looks like they can be reached ... they are on the left side of the box and right down in front...  

you might see if they are free to move...   or have someone work the controls while you look under the dash... see if you can see them move.. or start to move..

hope this helps...

there is more information.. and much more detailed...  at

eautorepair.net..   or alldatadiy.com...   both short subscription services... the same information the professional mechanics have at their workbench..


please be kind and post what you found...  as many other will read this in the future..  

Orcinius1 Orcinius1
New User | Posts: 2 | Joined: 12/09
Posted: 12/19/09
12:21 PM

I replaced the heater core and everything worked fine for like 3 months. I checked the actuators 10 and 11 and they are working fine. I have just a little bit of warm air that comes out the defrost and at the feet when you switch it to those, but the majority of the air comes out the vent still no matter what position the vent switch is in. What vacuum hose could be causing this and where would I find it?  

waynep7122 waynep7122
Addict | Posts: 4561 | Joined: 08/09
Posted: 12/19/09
04:20 PM

i don't have any more info at hand...

you might try moving each of the actuator rods...

see if they all work..   there may be more..

just because it all worked 3 months ago .. does not mean something never breaks after you fix one of the many parts...

if everything that worked 3 months ago kept working..  cars would never break...  

i am still amazed.. that at the end of the assembly lines.. with parts made by thousands of different people at different locations around the world.. come together well enough to allow a car to start when you turn the key for the first time...  

Xml
Showbuyersguide Hide2
Get a free and easy new car
price quote in minutes
Button Getmyprice

Research Categories:

Sponsored Links

 
 
  • Trade-in-Value.com