Ad Radar

Automotive Forums  Where Car Enthusiasts Go to Discuss Cars Online

  
 
 
Home | Active Posts | Search | Log In / Register | Terms | FAQs
Xml
Item Posts   

Code p0756 shift solenoid b performance

 
 | 
Ranger5r55e Ranger5r55e
New User | Posts: 2 | Joined: 08/09
Posted: 08/11/09
06:17 PM

Hi, there glad I found this forum. I have a ford ranger with a 5r55e automatic transmission that started giving me some shift issues recently. I got a code p0756 for solenoid b performance, had the solenoid replaced but didn't fix the problem.

The best way I can describe it is, after the engine and transmission warm up or open loop computer after about 5 minutes of driving, there is a loud "whirling" noise from the bellhouse(torque converter) followed by the haunting "clunk" into 2nd gear. I should also mention it is a shift 1-2 problem(huge pain in the arse for city driving). My best guess is there is some sort of vacuum or pressure control component that is not functioning properly. Anyone with any kind of knowledge of automatic transmissions, if you've had any experice with this from your vehicle, please feel free to drop a line! thanks!  

440t4 440t4
Guru | Posts: 1009 | Joined: 04/09
Posted: 08/11/09
07:05 PM

Is the code gone since you changed the solinoid? Are any other shifts too firm? A whinning from the bell housing can mean that the pump is not drawing enough fluid.Was the filter changed when the solinoid was replaced? Was that the only code you had {engine or trans}?  

Ranger5r55e Ranger5r55e
New User | Posts: 2 | Joined: 08/09
Posted: 08/12/09
03:22 PM

The code came back a couple weeks after I had the solenoid replaced. Shift 2-3 is occasionally rough but mostly just minor surging. 3-4 and 4-5 are good. Also sometimes it will not shift at all from 1-2 so I'll have to play around with the throttle for 10+ seconds to get it to shift. The filter was replaced with the solenoid. Thanks for the response, let me know if you can pinpoint any direct causes of the bad shift(s). Also, yeah there is a whining noise coming from the bellhouse on cold start.  

440t4 440t4
Guru | Posts: 1009 | Joined: 04/09
Posted: 08/13/09
03:38 PM

Code PO756 is solinoid B  performance stuck off.This can be either the solinoid itself {which you already replaced} or electrical.The first thing to do is check the internal transmission wire harness.You would need the ATSG manual and an ohm meter to do this.You would obviously check the wires relating to solinoid B.You should have good continuety if the harness is ok {very little or no resistance}.Or you could check it from the outside of the trans {the pins for sol B}and then the resistance should be within the specs provided in the manual for sol B.If the internal harness checks out ok then your problem is in the main harness going from the computer to the trans.

PS:It might be possible that the computer itself is no good even though it wasnt listed as a possible problem for that code.  

snyderman76 snyderman76
New User | Posts: 1 | Joined: 11/09
Posted: 11/18/09
06:36 PM

i have seen this code set before because of valves sticking in the valve body not from any electrical or solenoid issue at all  

440t4 440t4
Guru | Posts: 1009 | Joined: 04/09
Posted: 11/18/09
11:25 PM

Since it took two weeks for the code to come back sticking valves are a good possibility.The whinning convertor could mean that there is metal in the system.If the computer commands 2nd and 2nd doesnt engage the computer may think the solinoid is not coming on.His "clunk" into 2nd might actually be a 1-3 shift.I believe he said the problem does not occur until the trans gets hot and goes into closed loop.which does not really go along with stuck valves. Its hard to say without driving the vehicle yourself.  

Xml
Showbuyersguide Hide2
Get a free and easy new car
price quote in minutes
Button Getmyprice

Research Categories:

Sponsored Links

 
 
  • Trade-in-Value.com