Automotive Forums  Where Car Enthusiasts Go to Discuss Cars Online

  
 
 
Home | Active Posts | Search | Log In / Register | Terms | FAQs
Xml
Item Posts   

1998 Ford Escort Hard Start - Hesitation - Stall

 
 | 
buzzard buzzard
New User | Posts: 3 | Joined: 02/07
Posted: 02/18/07
03:11 PM

I'm looking at my neices 98 Escort and she has spent a ton at dealers  and her car is still not fixed. I have a 25 year background with GM cars but not so familiar with Fords. Here are the symptoms:

10 second or more crank time to start, or 3 tries with the key. (always 3 ???)

Rough idle (intermittant)

Stalling (mainly on corners when you let up the gas)

If throttle is pressed ore than approx. 1/3 the engine just bogs. It still pulls the car but no power. Let her up to about 1/3 throttle and it goes like a bat out of *** Sometimes when you get into the throttle too far it will stall as well.

The CEL is not on although I don't have the Ford dianostic tool to check any history. Looks like dealer has replaced:

All ign. components
Battery, Alternator
Filters
Who know what else.

I have check grounds and for vaccum leaks. All seem OK.

I pulled the EEC as I wanted to so a sweep test on the TPS but the only diagram I had was wrong.

My instict is telling me TPS however not being all that familiar with these babies I thought I would get a few opinions. Vehicle is a 4 cylinder with Canada Emissions is it makes a difference.  

nickb2 nickb2
Guru | Posts: 816 | Joined: 08/06
Posted: 02/18/07
04:04 PM

pull the code first, but check the MAF, fuel pressure reg, or fuel pump are all very common issues on those cars

Nick
ASE Master Auto Technician, L1  
ASE Master Auto Technician, L1, ASE Certified Service Consultant, ASE Certified Parts Specialist, Chrysler Certified Service Manager/Technician

buzzard buzzard
New User | Posts: 3 | Joined: 02/07
Posted: 02/19/07
05:54 PM

Forgot
Had battery disconected. That will clear any history codes???? Check Engine Light has NOT been on since I started working on car. Drove for a while today, let it miss, bog, stall, you name it for an hour or more. No check engine light. You would think that many continous conditions would throw a code...  

buzzard buzzard
New User | Posts: 3 | Joined: 02/07
Posted: 02/20/07
02:07 PM

Well, learned a bit more how this things acts today. I put some gas in it which took it over the 1/2 tank. It now runs great with the exception of the transmission kickdown keeps it in a lower gear until what seems like fuel cut. This thing must have a rusty fuel pickup, a hole in the pickup or something. Thoughts? Also, how do you adjust the kickdown on this thing? No Adjustment at TB. Cablee goes into what looks like a module at the right fender. Thanks guys.  

nvrose nvrose
New User | Posts: 2 | Joined: 04/07
Posted: 04/05/07
07:15 PM

Icon Quotebuzzard:
I'm looking at my neices 98 Escort and she has spent a ton at dealers  and her car is still not fixed. I have a 25 year background with GM cars but not so familiar with Fords. Here are the symptoms:

10 second or more crank time to start, or 3 tries with the key. (always 3 ???)

Rough idle (intermittant)

Stalling (mainly on corners when you let up the gas)

If throttle is pressed ore than approx. 1/3 the engine just bogs. It still pulls the car but no power. Let her up to about 1/3 throttle and it goes like a bat out of *** Sometimes when you get into the throttle too far it will stall as well.

The CEL is not on although I don't have the Ford dianostic tool to check any history. Looks like dealer has replaced:

All ign. components
Battery, Alternator
Filters
Who know what else.

I have check grounds and for vaccum leaks. All seem OK.

I pulled the EEC as I wanted to so a sweep test on the TPS but the only diagram I had was wrong.

My instict is telling me TPS however not being all that familiar with these babies I thought I would get a few opinions. Vehicle is a 4 cylinder with Canada Emissions is it makes a difference.


Have you solved this problem yet?  I am having the exact same problems with my 1998 Escort!  Always three turns of the key or at least 10 seconds of the engine trying to turn over before it finally starts.  Mine doesn't stall, though.  I'm  not sure where to start.  I have very little money for repairs and I'm new to town, so I don't know who to take it to.  No one I know is familiar at all with cars.  Any advice you have would be helpful for me to take to the garage when I finally have the cash to take it in.  

nvrose nvrose
New User | Posts: 2 | Joined: 04/07
Posted: 06/07/08
09:20 PM

Turned out to be the fuel pump.  Replaced nearly a year ago and no problems since.  

Xml
Showbuyersguide Hide2
Get a free and easy new car
price quote in minutes
Button Getmyprice

Research Categories:

Sponsored Links

 
 
  • Trade-in-Value.com